Telehealth Supported Devices and Browsers

Most modern devices will work fine.  It's important to ensure your browser is up-to-date.  Here is a summary of the browsers to use for each operating system:


Chrome
Firefox Safari   Edge*
Windows Y Y - Y
MacOS Y Y Y -
iOS (iPhone/iPad)** - - Y -
Android Y N - -

*Edge must be version 80.x or higher. **Apple does not give other browsers access to the camera meaning you must use Safari. 

We have tested the latest versions of the following devices and browsers:

Mobile

  • iPhone with Safari
  • Samsung with Chrome

Tablet

  • iPad with Safari 

Notebook and Desktop

MacOs

  • Safari 13
  • Chrome
  • Firefox

Windows 10

  • Chrome
  • Edge (Must be version 80 of higher)
  • Firefox
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us